Advertisements

Tektronix AM503 Current Probe Amplifier: DC Level Fix

One of my Tektronix AM503 Hall Effect Current Probe Amplifiers (B075593, for future reference) lost its DC Level zero-ing capability:

Tek AM503 front panel

Tek AM503 front panel

The front-panel knob produced only positive output voltages from maybe 50 mV to the amp’s upper limit around 200 mV (into a 50 Ω termination, Tek not being one to fool around with signal quality & bandwidth). Other than that, the amp seemed to work fine, but you definitely want a 0 V baseline corresponding to no current through the Hall probe.

The manual includes troubleshooting recommendations:

Tek AM503 Amplifier - troubleshooting zero set problems

Tek AM503 Amplifier – troubleshooting zero set problems

Because I didn’t understand the circuitry, I check the supply voltages, then started at U350, the differential amp rubbing the DC level knob against the input signal, and worked outward in both directions (clicky for more dots):

Tek AM503 Current Probe Amplifier - p 61 - Output Amplifier schematic

Tek AM503 Current Probe Amplifier – p 61 – Output Amplifier schematic

The PCB looks like this:

Tek AM503 - Q230 PCB detail

Tek AM503 – Q230 PCB detail

U350 is the round epoxy package in the the square spider-leg array over on the far left. Contrary to what you (well, I) might think, the index mark denotes pin 16, not pin 1:

Tek AM503 Amplifier - Tek-unique IC pinout reference

Tek AM503 Amplifier – Tek-unique IC pinout reference

Which puts pin 1 at the upper right corner of the package on the PCB. The part listing in the manual says MICROCKT,LINEAR:VERTICAL AMPLIFIER / SELECTED, which makes perfect sense given Tek’s oscilloscope business; if you needed a high-speed differential amplifier, that’s what Tek’s internal catalog would surely suggest. Newer AM503 revisions use somewhat less unobtainable op amps, although they replace the DC Level knob with one of those newfangled microcontroller thingies for some sweet auto-leveling action.

Nothing seemed out of order. The unable-to-zero condition pushed the bias voltages off the expected values, but nothing seemed completely out of whack / stuck at the rails / broken.

The problem turned out to be in Q230, the first item on Tek’s checklist after the power supplies, even though its bias voltages looked OK. It produces the “Attenuated AC Signal” seen above and lives on another page of the schematics:

Tek AM503 Amplifier - Q230 detail

Tek AM503 Amplifier – Q230 detail

Q230 is clad in the natty red heatsink in the PCB picture above. CR226 is the metal TO-18-ish can partially hidden by the orange-red-brown ribbon cable from the DC Level pot.

For future reference, C234 and C244 aren’t installed in this PCB; they’d fit in the conspicuously vacant spots to the right and in front of Q230.

What may not be obvious at a first glance: Q230’s pins sit in teeny individual sockets installed in the PCB. One might remove and reinstall Q230, should one be so inclined and, given that it’s the first active device after the input attenuator, one might imagine such an action being necessary after a catastrophic oopsie.

At this late date, finding a suitable dual JFET would be … difficult, even were one were willing to compromise on the hermetic metal TO-78A package.

Seeing as how Q230 has been sitting quietly in its socket for the last three decades, I proceeded cautiously:

  • Turned the power off
  • Waited for the supply voltages to drop
  • Pulled Q230 slightly upward
  • Wiggled-and-jiggled it around
  • Shoved it back down
  • Turned the power on

I heroically refrained from pulling it completely out of its socket to dab DeoxIT on the pins; JFETs being notorious for susceptibility to static damage and, likely, lube would make no difference anyway.

Fired that devil up and the DC Level knob resumed doing exactly what it should:

Tek AM503 - Q230 reseated

Tek AM503 – Q230 reseated

The output now has the usual ±200 mV range centered at 0 V. The waveform shows a 100 mA signal at 50 mA/div, produced by a bench supply into a 100 Ω power resistor switched by a DC-DC SSR.

Whew & similar remarks.

Moral of the story: it’s always the connector!

Advertisements

  1. #1 by madbodger on 2018-08-16 - 08:13

    Those teeny PCB mount “sockets” are nifty little things, silicone filled even. They were the “Minisert” line made by FCI (AKA Berg AKA Framatome AKA Amphenol), no longer available (last shipment 14 May 2010). Part number 75540-002 (a web search brings up nice pictures, data sheets, etc. from the usual suppliers).

    • #2 by Ed on 2018-08-16 - 20:43

      Silicone filled: those Tek engineers thought of everything!

      But if those amps ever stop working for a nontrivial reason, there’s no way back …

      • #3 by madbodger on 2018-08-16 - 21:19

        You might be surprised, InterFET still makes a TO-78 cased 2N5911 (which they of course call an IFN5911). About $15 apiece, but they exist.

        • #4 by Ed on 2018-08-17 - 11:33

          I devoutly hope to never need such a thing …

  1. Tektronix AM503 Current Probe Amplifier: Failed Electrolytic Capacitor | The Smell of Molten Projects in the Morning
  2. Powered Prototype Board: Laying-on of Hands Repair | The Smell of Molten Projects in the Morning

Spam comments vanish. Comment moderation may cause a delay.

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s