Advertisements

Toyota Sienna: Rear ABS / Speed Sensor Failure

Given a hint that the Sienna’s left rear ABS / speed sensor had failed, we took a look:

Sienna ABS failure - removing lug nuts

Sienna ABS failure – removing lug nuts

She removed the wheel under field conditions using only in-the-car tools for practice, with the jack stand and wheel chock because we weren’t really beside the road. It turned out that breaking The Last Lug free required bouncing her full weight on the wrench handle, which is what we expected based on previous experience.

Yes, I pointed out the inadequacy of that footwear. Yes, she loosened the lugs before jacking the van.

With the van up, the first look showed the ABS diagnostic blink code was dead on:

Sienna ABS failure - sensor cable

Sienna ABS failure – sensor cable

That bit of tubing in her fingers should contain a pair of wires, which was a bit of a puzzle.

The connector remained snapped onto the sensor head, but the whole affair came out easily enough:

Sienna ABS failure - connector on sensor head

Sienna ABS failure – connector on sensor head

We thought those wires seemed very tightly twisted, too. I guessed that a clip holding the sensor head in place had gone missing, allowing it to rotate in place.

Which was partially true, as the “missing” wires were very very very tightly twisted inside that flexible tubing and, thus, much shorter than they should be:

Sienna ABS failure - hypertwisted sensor cable

Sienna ABS failure – hypertwisted sensor cable

Lining up the removable parts:

Sienna ABS failure - sensor head disassembly

Sienna ABS failure – sensor head disassembly

The sensor head should be firmly glued onto the back of the wheel hub, with no clips or screws holding it in place, as we found by comparing it with the right rear wheel. That slightly rough gray ring just outside of the central cylinder was the adhesive…

She soldered longer wires to the pigtails on the connector and applied heatshrink. The hyper-twisted wires under the car got un-twisted a bit, straightened, cleaned up, then rejoined to the connector with pair of gel-filled beanie compression splices and more tubing to ease the strain.

We buttered up the sensor head flange with JB Kwik epoxy, squished it back in place for a good seal, spun the hub to make sure the sensor fingers weren’t hitting anything, then she practiced ten minutes of meditation while holding it in place and awaiting a firm set.

It turns out that the sensor head is not a replaceable part: it’s factory-bonded to the back of the hub and should never, ever come loose. Given that this one had made maybe a dozen orbits and was finger-loose in the back of the hub, with some dust & crud visible inside the hub where it shouldn’t be, replacing the wheel hub is in the plan.

Also, we still don’t know why different versions of “the same cable” have such a huge price difference; despite their sensor attribute, they definitely don’t include the sensor head.

After repairing the cable, she put the wheel back in place, reset the ABS codes, drove the van around the block, found a patch of sand to check out the ABS braking, and reported normal operation.

We’ll replace both the cable and hub, then declare victory.

Advertisements

  1. #1 by Ken Davidson on 2015-06-10 - 08:55

    Isn’t it great having a college-age daughter who isn’t afraid of mechanical things? My oldest has been able to drive her 1997 Taurus to and from school three hours away with reduced braking (steel brake line leak), no power steering (serpentine belt idler broke), and a finicky transmission (she knows exactly where to put fluid in). I had to do parking lot repairs down at school for the first two problems. She’ll open the hood and point out different systems and fluid reservoirs to friends who can’t understand how she knows these things. With the leaking brake line, on her own she cleaned up the lines, wrapped paper towels around them, stepped on the brake, and pinpointed the leak so she could tell me over the phone where the problem was.

    • #2 by Ed on 2015-06-10 - 14:50

      Aye!

      She reports very few of her compadres at RIT make physical things (!), so I think the grime under her fingernails will be the visible mark of her superpower…

  2. #3 by hexley ball on 2015-06-10 - 11:59

    Kind of a mystery how that sensor got knocked loose. It does remind me that some cars caution about using tire chains, lest they damage the ABS sensor. I doubt you would have had cause to run chains on the rear wheels, though.

    Good job by your daughter on the jacking and tire removal job. But maybe run her through the Red Wing shoe store on her next birthday, Dad :-)

    • #4 by Ed on 2015-06-10 - 15:06

      Red Wing shoe store

      The time when I had any influence on her sartorial decisions is long gone… [grin]

    • #5 by Frans on 2015-06-17 - 16:45

      On the contrary, point her to xeroshoes.com or similar. grins

  3. #6 by Daniel B. Martin on 2015-06-11 - 10:11

    http://www.ebay.com/itm/ABS-Wheel-Speed-Sensor-Connector-Rear-Left-Standard-fits-98-03-Toyota-Sienna-/171544038521?fits=Make%3AToyota|Model%3ASienna&hash=item27f0d24c79&vxp=mtr

    [Ed: I tried and failed to make that link clickable. WordPress evidently can’t handle a pipe character in the middle of a link.]

    • #7 by Ed on 2015-06-11 - 12:18

      We picked one up from the local parts store for about the same price after shipping & tax, so that’s about what they cost.

      At least they’re more descriptive: “sensor connector”.