Advertisements

Archive for July 4th, 2017

Canon LiDE 120 Scanner vs. SANE

I just replaced a cheap old Canon LiDE 30 flatbed scanner with a cheap new LiDE 120, only to get flat-black scans. The machinery worked (yes, I released the travel lock), everything seemed fine, the images were the proper size, but they were dead black.

Of course, the scanner worked OK on the Token Windows Box, but wow what crappy software they include.

Turns out the LiDE 120 requires the latest-and-greatest version 1.0.27 of the various SANE programs & libraries. Mercifully, getting those didn’t require compiling from source, just setting up the maintainer’s PPA of the most recent stable release:

sudo add-apt-repository ppa:rolfbensch/sane-release
sudo apt-get update
sudo apt-get upgrade

Which introduced circular dependencies with the distro-installed version 1.0.25 files, which I solved by ripping the entire SANE Thing out by the root(s) and reinstalling it to (re)synchronize All The Things:

sudo apt-get remove libsane:i386 sane sane-utils xsane libsane-common ia32-libs libsane
sudo apt-get install libsane:i386 sane sane-utils xsane libsane-common ia32-libs libsane

And then It Just Worked:

C-Note - detail

C-Note – detail

Of course, you must keep this WARNING in mind:

Canon LiDE 120 - Legal Issues Warning

Canon LiDE 120 – Legal Issues Warning

Franklin didn’t know about scanners or color laser printers when he observed:

Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety

Of course, there’s more to the story, but one should:

Never let the truth get in the way of a good story.

Advertisements

2 Comments