Advertisements

Archive for October 1st, 2011

Kensington Trackball: Scroll Ring Tweakage

Of late, something in the pile of input devices attached to my main PC has been feeding occasional bursts of upward scroll commands, to the extent that editing long documents (something I do quite a bit of, oddly enough) was becoming difficult. By process of elimination, the culprit turned out to be the Kensington trackball to the left of the keyboard: unplugging it eliminated the problem.

Having had problems with that thing before and having gotten considerable feedback from other folks, I had a general idea of how to proceed: putz with the IR emitter-detector pair, but not very much. A side view of the pair with the trackball cup and scroll ring removed:

Scroll ring IR emitter-detector quadrature pair

Scroll ring IR emitter-detector quadrature pair

Now, what’s weird about that setup is that the detector lens seems to be pointing in the wrong direction: away from the emitter’s lens. You know it’s the detector because it’s tinted: there’s no point in filtering the emitter’s output (although I have seen gray-tinted IR LEDs, which I think is just to mark them as different from visible LEDs). Here’s proof: a pure IR picture from my Sony DSC-F717 in Nightshot (a.k.a. IR) mode through a Hoya R72 visible-block filter:

Quadrature pair in pure IR

Quadrature pair in pure IR

Some possibilities for why the detector is backwards:

  • It’s an assembly screwup (unlikely, but possible)
  • That’s not a lens, it’s a locating tab (different on emitter & detector?)
  • The backside uses the metal conductors as slits to enhance the signal (my favorite)

Here’s a grossly image-enhanced blowup of the detector from that picture:

Quadrature IR detector in pure IR - detail

Quadrature IR detector in pure IR – detail

The case becomes transparent in pure IR, so you can see the metal lead frame inside. I think they’re using the gaps between the leads to enhance the contrast of the scroll ring edges passing through the beam: absolutely no IR except when a gap aligns with a scroll ring opening.

[Update: read the comments for a different interpretation; I’m probably wrong.]

That would also explain why the pair seems so sensitive to alignment: there’s very little IR hitting the detector, because the IR illumination passes through the transparent-to-IR case and vanishes out the far side, with only a tiny bit reflected to the sensor!

Anyhow, I pushed the pair minutely toward each other, just enough to feel the leads bend, and put everything back together. So far it seems to be working perfectly, but it’s done that before …

[Comment: Jack found a different solution that might produce better results:

Just got the Problem with my Scroll ring and thanks to your blog i digged a bit deeper.

here is the Solution for my Problem:

I checked this while connected and i found that bending worked only for a short time, so i gave a closer look to the contacts.

all are soldered from below BUT two contacts are on the upper side.
normaly solder should flow into but here it was as simple as just resolder the receiver with enough solder an its now working again. (btw a realigned the magnet to get a better response)

Thanks
Jack

ps. the size of the cuts in the metall from the scroll ring differ, a shame for that price..

It’s certainly worth trying, particularly when your Expert Mouse trackball isn’t working…

Advertisements

20 Comments